Page 2 sur 2 PremièrePremière 12
Affichage des résultats 11 à 19 sur 19

Discussion: Quel est le module qui compile chan_dahdi.so?

  1. #11
    Membre Senior
    Date d'inscription
    septembre 2010
    Localisation
    Where the sun shines
    Messages
    1 418
    Downloads
    0
    Uploads
    0
    je t'ai envoyé des traces en mp d'une de mes machines

  2. #12
    Membre Association
    Date d'inscription
    aot 2010
    Messages
    856
    Downloads
    0
    Uploads
    0
    Ne pas oublier le paquet kernel-devel correspondant au kernel installé.
    Penser à stopper Asterisk, à stopper et décharger dahdi (voir avec lsmod si il reste des modules chargés)

    Pour dahdi-linux:
    make
    make install

    Pour dahdi-tools:
    ./configure
    make menuselect
    make
    make install
    make config

    Pour libpri, ne pas installer les paquets de la distrib, compilez comme le reste.
    make
    make install

    Pour asterisk:
    ./configure
    make menuselect <= on doit voir dahdi validé, sinon pas la peine d'aller plus loin.
    make
    make install
    make samples
    make config

    Pas besoin d'effacer le répertoire et ré-extraire l'archive:
    make clean efface le résultat de la compilation avec make
    make distclean efface aussi ce qui est fait par ./configure

  3. #13
    Membre Junior
    Date d'inscription
    octobre 2010
    Messages
    19
    Downloads
    0
    Uploads
    0
    Citation Envoyé par ffossard Voir le message
    make menuselect <= on doit voir dahdi validé, sinon pas la peine d'aller plus loin.
    Voilà bien le problème.
    J'ai demandé à yum de retirer libpri et je l'ai compilé (Il fonctionnait avant!).
    Je suis toujours au même point.
    Sauf que maintenant il (menuselect) demande openr2!!!!

    yum ne le trouve pas et je n'arrive pas à le compiler.

    Merci.

    Bye,
    Jean-Louis

  4. #14
    Membre Junior
    Date d'inscription
    octobre 2010
    Messages
    19
    Downloads
    0
    Uploads
    0
    Hi,

    Citation Envoyé par ffossard Voir le message
    make menuselect <= on doit voir dahdi validé, sinon pas la peine d'aller plus loin.
    Bon, pour résoudre ce problème j'ai "downgradé" jusqu'au moment où il compile chan_dahdi. A partir de 1.6.2.13 et plus bas c'est OK. Plus haut il refuse de compiler chan_dahdi.

    Bye,
    Jean-Louis

  5. #15
    Membre Junior
    Date d'inscription
    octobre 2010
    Messages
    19
    Downloads
    0
    Uploads
    0
    Citation Envoyé par ffossard Voir le message
    make menuselect <= on doit voir dahdi validé, sinon pas la peine d'aller plus loin.
    Après être parvenu à compiler openr2 (j'ai retiré l'option -Werror)
    tout est parfais et la 1.6.2.19 a compilé chan_dahdi.

    J'ai rétabli la libpri de la distribution. Ne pas oublier d'installer libpri-devel aussi
    ou directement yum install libpri-devel ainsi que dahdi-linux-complete-2.4.1.2+2.4.1.

    Ce dont je suis certain c'est que je n'ai jamais compilé openr2 avant!

    Merci à tous.

    Bye,
    Jean-Louis

  6. #16
    Membre Association
    Date d'inscription
    aot 2010
    Messages
    856
    Downloads
    0
    Uploads
    0
    mais pourquoi ne pas compiler aussi libpri

  7. #17
    Membre Junior
    Date d'inscription
    octobre 2010
    Messages
    19
    Downloads
    0
    Uploads
    0
    Citation Envoyé par ffossard Voir le message
    mais pourquoi ne pas compiler aussi libpri
    Pour avoir le moins possible de module à upgrader manuellement.

    Bye,
    Jean-Louis

  8. #18
    Membre Senior
    Date d'inscription
    fvrier 2011
    Localisation
    Garges Les Gonesse
    Messages
    152
    Downloads
    0
    Uploads
    0
    Citation Envoyé par jln Voir le message
    Pour avoir le moins possible de module à upgrader manuellement.

    Bye,
    Jean-Louis
    bonjour,

    Tout dépend si vous installez des cartes comme TE2 qqc pour gérer les canaux E1 (T2 de FT ou autre ) ou encore une B410 pour gérer des T0 par exemple

    Si ce cas ,Il semble bien qu'il faille installer Libpri

    LibPRI is an open source library that implements signaling for ISDN-PRI and ISDN-BRI
    voir http://www.asterisk.org/libpri

    A+

  9. #19
    Membre Junior
    Date d'inscription
    octobre 2010
    Messages
    19
    Downloads
    0
    Uploads
    0
    Citation Envoyé par YBDOMO Voir le message
    Il semble bien qu'il faille installer Libpri
    Personne n'a dit qu'il ne fallait pas libpri!

    J'ai simplement écris que j'avais rétabli le libpri de la distribution!

    Bye,
    Jean-Louis

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •