Page 3 sur 4 PremièrePremière 1234 DernièreDernière
Affichage des résultats 21 à 30 sur 37

Discussion: Remontée de fiche SugarCrm avec Asterisk

  1. #21
    Membre
    Date d'inscription
    juin 2011
    Localisation
    Houilles
    Messages
    46
    Downloads
    3
    Uploads
    0
    Je te remercie Sylvain, pour tes explications.

    En suivant ton tuto à la lettre avec les versions 13.25 de Xivo et 6.5.16 de sugar, la remonté de fiche marche parfaitement.

    Enfin une solution CTI très stable

  2. #22
    Membre Association Avatar de quintana
    Date d'inscription
    aot 2010
    Localisation
    Québec
    Messages
    1 084
    Downloads
    0
    Uploads
    0
    Super , il y avait d'autre façon de faire aussi avec XiVO. C'est un peu la force de XiVO justement
    Bon ok je ne suis pas vraiment la bonne personne pour le dire, mais je le dit quand même !
    Hésites pas à partager ton expérience, ton tuto avec les captures d'écran est vraiment bien, si tu te sens de contribuer à faire un truc dans le wiki de XiVO ne te gène pas
    Découvrez Wazo sous licence GPLv3 et accessible pour tous : http://www.wazo.community
    Blog Wazo : http://blog.wazo.community
    Wazo est un fork de XiVO.
    Suivez moi sur Twitter !

  3. #23
    Membre
    Date d'inscription
    juin 2011
    Localisation
    Houilles
    Messages
    46
    Downloads
    3
    Uploads
    0
    Je le ferais car j'ai longtemps cherché à trouver une solution et je me focalisais trop sur le plug'in "YAAI" qui marchais aléatoirement.

  4. #24
    Membre
    Date d'inscription
    juin 2011
    Localisation
    Houilles
    Messages
    46
    Downloads
    3
    Uploads
    0
    Bonjour Sylvain,

    Je suis de retour :-) Bizarrement cela à fonctionné sur la machine de test mais pas sur la prod...
    J'ai l'impression que quand il connait le numéro l'appel n'aboutit pas (message d’indisponibilité) et quand le numéro n'est pas renseigné l'appel arrive bien et la fiche remonte vierge.

    Si ça te parle + rapidement que moi, j'aimerais bien comprendre d'ou ça vient

    voici la trace CLI d'un appel connu dans le CRM mais d'ou l'appel n'a pas aboutit (aucun des postes n'a sonné)

    Désolé de t’embêter avec ça, mais je comprend pas ce phénomène...

    [Jan 20 17:46:52] -- Executing [097223XXXX@from-extern:1] Set("SIP/trunk_ovh-000000f2", "XIVO_BASE_CONTEXT=from-extern") in new stack
    [Jan 20 17:46:52] -- Executing [097223XXXX@from-extern:2] Set("SIP/trunk_ovh-000000f2", "XIVO_BASE_EXTEN=097223XXXX") in new stack
    [Jan 20 17:46:52] -- Executing [097223XXXX@from-extern:3] Gosub("SIP/trunk_ovh-000000f2", "did,s,1(3,)") in new stack
    [Jan 20 17:46:52] -- Executing [s@did:1] Set("SIP/trunk_ovh-000000f2", "XIVO_DSTNUM=097223XXXX") in new stack
    [Jan 20 17:46:52] -- Executing [s@did:2] Set("SIP/trunk_ovh-000000f2", "XIVO_CONTEXT=from-extern") in new stack
    [Jan 20 17:46:52] -- Executing [s@did:3] Set("SIP/trunk_ovh-000000f2", "XIVO_PRESUBR_GLOBAL_NAME=DID") in new stack
    [Jan 20 17:46:52] -- Executing [s@did:4] Set("SIP/trunk_ovh-000000f2", "XIVO_INCALL_ID=3") in new stack
    [Jan 20 17:46:52] -- Executing [s@did:5] Set("SIP/trunk_ovh-000000f2", "__XIVO_CALLORIGIN=extern") in new stack
    [Jan 20 17:46:52] -- Executing [s@did:6] AGI("SIP/trunk_ovh-000000f2", "agi://127.0.0.1/callerid_extend") in new stack
    [Jan 20 17:46:52] agi://127.0.0.1/callerid_extend: AGI handler 'callerid_extend' successfully executed
    [Jan 20 17:46:52] -- <SIP/trunk_ovh-000000f2>AGI Script agi://127.0.0.1/callerid_extend completed, returning 0
    [Jan 20 17:46:52] -- Executing [s@did:7] AGI("SIP/trunk_ovh-000000f2", "agi://127.0.0.1/in_callerid") in new stack
    [Jan 20 17:46:52] agi://127.0.0.1/in_callerid: AGI handler 'in_callerid' successfully executed
    [Jan 20 17:46:52] -- <SIP/trunk_ovh-000000f2>AGI Script agi://127.0.0.1/in_callerid completed, returning 0
    [Jan 20 17:46:52] -- Executing [s@did:8] AGI("SIP/trunk_ovh-000000f2", "agi://127.0.0.1/callerid_forphones") in new stack
    [Jan 20 17:46:52] agi://127.0.0.1/callerid_forphones: AGI handler 'callerid_forphones' successfully executed
    [Jan 20 17:46:52] -- <SIP/trunk_ovh-000000f2>AGI Script agi://127.0.0.1/callerid_forphones completed, returning 0
    [Jan 20 17:46:52] -- Executing [s@did:9] UserEvent("SIP/trunk_ovh-000000f2", "ReverseLookup,CHANNEL: SIP/trunk_ovh-000000f2,") in new stack
    [Jan 20 17:46:52] -- Executing [s@did:10] Set("SIP/trunk_ovh-000000f2", "XIVO_SRCNUM=095155XXXX") in new stack
    [Jan 20 17:46:52] -- Executing [s@did:11] Gosub("SIP/trunk_ovh-000000f2", "xivo-did_rights_check,s,1") in new stack
    [Jan 20 17:46:52] -- Executing [s@xivo-did_rights_check:1] AGI("SIP/trunk_ovh-000000f2", "agi://127.0.0.1/did_set_call_rights") in new stack
    [Jan 20 17:46:52] agi://127.0.0.1/did_set_call_rights: AGI handler 'did_set_call_rights' successfully executed
    [Jan 20 17:46:52] -- <SIP/trunk_ovh-000000f2>AGI Script agi://127.0.0.1/did_set_call_rights completed, returning 0
    [Jan 20 17:46:52] -- Executing [s@xivo-did_rights_check:2] GotoIf("SIP/trunk_ovh-000000f2", "ALLOW?:error,1") in new stack
    [Jan 20 17:46:52] -- Executing [s@xivo-did_rights_check:3] GotoIf("SIP/trunk_ovh-000000f2", "1?allow,1") in new stack
    [Jan 20 17:46:52] -- Goto (xivo-did_rights_check,allow,1)
    [Jan 20 17:46:52] -- Executing [allow@xivo-did_rights_check:1] NoOp("SIP/trunk_ovh-000000f2", "Caller allowed to make call") in new stack
    [Jan 20 17:46:52] -- Executing [allow@xivo-did_rights_check:2] Return("SIP/trunk_ovh-000000f2", "") in new stack
    [Jan 20 17:46:52] -- Executing [s@did:12] AGI("SIP/trunk_ovh-000000f2", "agi://127.0.0.1/incoming_did_set_features") in new stack
    [Jan 20 17:46:52] agi://127.0.0.1/incoming_did_set_features: AGI handler 'incoming_did_set_features' successfully executed
    [Jan 20 17:46:52] -- <SIP/trunk_ovh-000000f2>AGI Script agi://127.0.0.1/incoming_did_set_features completed, returning 0
    [Jan 20 17:46:52] -- Executing [s@did:13] UserEvent("SIP/trunk_ovh-000000f2", "Did,XIVO_SRCNUM: 095155XXXX,XIVO_SRCNAME: ,XIVO_EXTENPATTERN: 097223XXXX,CHANNEL: SIP/trunk_ovh-000000f2,XIVO_SRCTON: 0,XIVO_SRCRDNIS: ") in new stack
    [Jan 20 17:46:52] -- Executing [s@did:14] AGI("SIP/trunk_ovh-000000f2", "agi://127.0.0.1/check_schedule") in new stack
    [Jan 20 17:46:52] agi://127.0.0.1/check_schedule: AGI handler 'check_schedule' successfully executed
    [Jan 20 17:46:52] -- <SIP/trunk_ovh-000000f2>AGI Script agi://127.0.0.1/check_schedule completed, returning 0
    [Jan 20 17:46:52] -- Executing [s@did:15] GotoIf("SIP/trunk_ovh-000000f2", "0?CLOSED,1") in new stack
    [Jan 20 17:46:52] -- Executing [s@did:16] Gosub("SIP/trunk_ovh-000000f2", "xivo-subroutine,s,1(sub-sugarcrm)") in new stack
    [Jan 20 17:46:52] -- Executing [s@xivo-subroutine:1] GotoIf("SIP/trunk_ovh-000000f2", "sub-sugarcrm?:nosubroutine") in new stack
    [Jan 20 17:46:52] -- Executing [s@xivo-subroutine:2] GotoIf("SIP/trunk_ovh-000000f2", "1?:nosubroutine") in new stack
    [Jan 20 17:46:52] -- Executing [s@xivo-subroutine:3] Gosub("SIP/trunk_ovh-000000f2", "sub-sugarcrm,s,1") in new stack
    [Jan 20 17:46:52] -- Executing [s@sub-sugarcrm:1] NoOp("SIP/trunk_ovh-000000f2", ""Get information from SUGARCRM"") in new stack
    [Jan 20 17:46:52] -- Executing [s@sub-sugarcrm:2] Set("SIP/trunk_ovh-000000f2", "SUGARCRM_URL=http://crm.XXXX.com/service/v4_1/rest.php") in new stack
    [Jan 20 17:46:52] -- Executing [s@sub-sugarcrm:3] Set("SIP/trunk_ovh-000000f2", "SUGARCRM_USERNAME=XXXX") in new stack
    [Jan 20 17:46:52] -- Executing [s@sub-sugarcrm:4] Set("SIP/trunk_ovh-000000f2", "SUGARCRM_PASSWD=XXXX") in new stack
    [Jan 20 17:46:52] -- Executing [s@sub-sugarcrm:5] AGI("SIP/trunk_ovh-000000f2", "xivo-sugarcrm/for_xivo") in new stack
    [Jan 20 17:46:52] -- Launched AGI Script /usr/share/asterisk/agi-bin/xivo-sugarcrm/for_xivo
    [Jan 20 17:46:52] xivo-sugarcrm/for_xivo: Trying to connect http://crm.XXXX.com/service/v4_1/rest.php with Asterisk : XXXX
    [Jan 20 17:46:57] xivo-sugarcrm/for_xivo: CONTACT : Damien Soulages
    [Jan 20 17:46:57] -- <SIP/trunk_ovh-000000f2>AGI Script xivo-sugarcrm/for_xivo completed, returning 4
    [Jan 20 17:46:57] == Spawn extension (sub-sugarcrm, s, 5) exited non-zero on 'SIP/trunk_ovh-000000f2'

  5. #25
    Membre
    Date d'inscription
    juin 2011
    Localisation
    Houilles
    Messages
    46
    Downloads
    3
    Uploads
    0
    Le problème provient du serveur CRM en lui même et non de xivo, car quand je met mon crm de test, l'appel arrive sans problème qu'il soit reconnu ou non dans les fiches contact.
    Mais avec le crm de prod, si la fiche est reconnu l'appel n'aboutit pas.
    Pour le moment la seul différence que je vois c'est que mon crm de test à une URL de type http://37.187.XX.XXX et celui en prod c'est du style : http://crm.airXXXX.com/

  6. #26
    Membre
    Date d'inscription
    juin 2011
    Localisation
    Houilles
    Messages
    46
    Downloads
    3
    Uploads
    0
    Je continu de chercher...
    Ce n'est pas un probleme d'URL

    La différence dans les log (CLI) que j'obtien est :

    OK:
    [Jan 21 07:20:18] xivo-sugarcrm/for_xivo: CONTACT : dams Sales
    [Jan 21 07:20:18] -- <SIP/trunk_ovh-0000012d>AGI Script xivo-sugarcrm/for_xivo completed, returning 0
    [Jan 21 07:20:18] -- Executing [s@sub-sugarcrm:6] UserEvent("SIP/trunk_ovh-0000012d", "dialplan2cti,UNIQUEID: 1390285216.301,CHANNEL: SIP/trunk_ovh-0000012d,VARIABLE: sugarcrm-firstname,VALUE: ") in new stack
    [Jan 21 07:20:18] -- Executing [s@sub-sugarcrm:7] UserEvent("SIP/trunk_ovh-0000012d", "dialplan2cti,UNIQUEID: 1390285216.301,CHANNEL: SIP/trunk_ovh-0000012d,VARIABLE: sugarcrm-lastname,VALUE: dams Sales") in new stack
    [Jan 21 07:20:18] -- Executing [s@sub-sugarcrm:8] UserEvent("SIP/trunk_ovh-0000012d", "dialplan2cti,UNIQUEID: 1390285216.301,CHANNEL: SIP/trunk_ovh-0000012d,VARIABLE: sugarcrm-id,VALUE: 38e00d3c-0b0f-2788-a10d-52d024c154bf") in new stack

    NOK
    [Jan 21 07:24:41] xivo-sugarcrm/for_xivo: CONTACT : Damien Soulages
    [Jan 21 07:24:42] -- <SIP/trunk_ovh-00000133>AGI Script xivo-sugarcrm/for_xivo completed, returning 4
    [Jan 21 07:24:42] == Spawn extension (sub-sugarcrm, s, 5) exited non-zero on 'SIP/trunk_ovh-00000133'
    [Jan 21 07:24:43] == Using SIP RTP CoS mark 5
    [Jan 21 07:24:43] -- Executing [097223XXXX@from-extern:1] Set("SIP/trunk_ovh-00000134", "XIVO_BASE_CONTEXT=from-extern") in new stack
    [Jan 21 07:24:43] -- Executing [097223XXXX@from-extern:2] Set("SIP/trunk_ovh-00000134", "XIVO_BASE_EXTEN=097223XXXX") in new stack
    [Jan 21 07:24:43] -- Executing [097223XXXX@from-extern:3] Gosub("SIP/trunk_ovh-00000134", "did,s,1(3,)") in new stack

    ...

  7. #27
    Membre Association Avatar de quintana
    Date d'inscription
    aot 2010
    Localisation
    Québec
    Messages
    1 084
    Downloads
    0
    Uploads
    0
    Salut,

    Je suis en déplacement, mais je regarde cela à mon retour. Je serai sur le salon itpartners en février si jamais y a des gens qui y seront aussi
    Découvrez Wazo sous licence GPLv3 et accessible pour tous : http://www.wazo.community
    Blog Wazo : http://blog.wazo.community
    Wazo est un fork de XiVO.
    Suivez moi sur Twitter !

  8. #28
    Membre
    Date d'inscription
    juin 2011
    Localisation
    Houilles
    Messages
    46
    Downloads
    3
    Uploads
    0
    J'attend ton retour,

    Pour résumer mes recherches (parce que c'est assez étrange) :

    Quand un appel arrivant sur Xivo et qui est répertorier dans une fiche CRM, Xivo nous retourne une erreur : AGI Script xivo-sugarcrm/for_xivo completed, returning 4
    Il stop l’exécution du script

    Par contre quand un appel arrive et n'est pas enregistré dans une fiche CRM, tout se déroule correctement : AGI Script xivo-sugarcrm/for_xivo completed, returning 0

    Comme sur mon CRM de test je n'ai pas ce problème, j'ai donc comparer les paramètres avec celui de PROD :
    -Encodage par défaut des imports/Exports défini sur UTF-8 = OK
    -Paramètre Locaux = OK

    Impossible de comprendre pourquoi le script s’arrête quand il identifie une fiche CRM avec le numéro appelant...

    J'ai même essayé de désinstaller et recommencer l'installation de GIT mais rien y fait...

  9. #29
    Membre Association Avatar de quintana
    Date d'inscription
    aot 2010
    Localisation
    Québec
    Messages
    1 084
    Downloads
    0
    Uploads
    0
    Désolé j'ai pas eu le temps encore car je voyage trop, mais j'ai pas oublié ça doit venir surement de l'Agi le souci.
    Découvrez Wazo sous licence GPLv3 et accessible pour tous : http://www.wazo.community
    Blog Wazo : http://blog.wazo.community
    Wazo est un fork de XiVO.
    Suivez moi sur Twitter !

  10. #30
    Membre
    Date d'inscription
    juin 2011
    Localisation
    Houilles
    Messages
    46
    Downloads
    3
    Uploads
    0
    C'est pas pressé

    j'ai essayé de débugué.

    asterisk -r
    agi set debug on
    core set verbose 4


    Voila ce que j'ai (au moment ou ca plante) sur le CRM qui pose problème :

    ------------------------------------------------------------------------------------------------------------------------------------------------------------
    [Feb 11 19:40:17] <SIP/trunk_ovh-0000000a>AGI Rx << VERBOSE "CONTACT : Damien Soulages" 1
    [Feb 11 19:40:17] xivo-sugarcrm/for_xivo: CONTACT : Damien Soulages
    [Feb 11 19:40:17] <SIP/trunk_ovh-0000000a>AGI Tx >> 200 result=1
    [Feb 11 19:40:17] <SIP/trunk_ovh-0000000a>AGI Rx << SET VARIABLE "SUGARCRM-ID" "970a01ac-7ce0-45e4-9776-51c5de4b3e99"
    [Feb 11 19:40:17] <SIP/trunk_ovh-0000000a>AGI Tx >> 200 result=1
    [Feb 11 19:40:17] <SIP/trunk_ovh-0000000a>AGI Rx << SET VARIABLE "SUGARCRM-FIRSTNAME" "Damien"
    [Feb 11 19:40:17] <SIP/trunk_ovh-0000000a>AGI Tx >> 200 result=1
    [Feb 11 19:40:17] <SIP/trunk_ovh-0000000a>AGI Rx << SET VARIABLE "SUGARCRM-LASTNAME" "Soulages"
    [Feb 11 19:40:17] <SIP/trunk_ovh-0000000a>AGI Tx >> 200 result=1
    [Feb 11 19:40:18] -- <SIP/trunk_ovh-0000000a>AGI Script xivo-sugarcrm/for_xivo completed, returning 4
    [Feb 11 19:40:18] == Spawn extension (sub-sugarcrm, s, 5) exited non-zero on 'SIP/trunk_ovh-0000000a'
    -----------------------------------------------------------------------------------------------------------------------------------------------------------


    Et le même test avec le CRM qui fonctionne :

    [Feb 11 20:05:02] <SIP/trunk_ovh-0000000d>AGI Rx << VERBOSE "CONTACT : dams Sales" 1
    [Feb 11 20:05:02] xivo-sugarcrm/for_xivo: CONTACT : dams Sales
    [Feb 11 20:05:02] <SIP/trunk_ovh-0000000d>AGI Tx >> 200 result=1
    [Feb 11 20:05:02] <SIP/trunk_ovh-0000000d>AGI Rx << SET VARIABLE "SUGARCRM-ID" "38e00d3c-0b0f-2788-a10d-52d024c154bf"
    [Feb 11 20:05:02] <SIP/trunk_ovh-0000000d>AGI Tx >> 200 result=1
    [Feb 11 20:05:02] <SIP/trunk_ovh-0000000d>AGI Rx << SET VARIABLE "SUGARCRM-FIRSTNAME" ""
    [Feb 11 20:05:02] <SIP/trunk_ovh-0000000d>AGI Tx >> 200 result=1
    [Feb 11 20:05:02] <SIP/trunk_ovh-0000000d>AGI Rx << SET VARIABLE "SUGARCRM-LASTNAME" "dams Sales"
    [Feb 11 20:05:02] <SIP/trunk_ovh-0000000d>AGI Tx >> 200 result=1
    [Feb 11 20:05:03] -- <SIP/trunk_ovh-0000000d>AGI Script xivo-sugarcrm/for_xivo completed, returning 0
    [Feb 11 20:05:03] -- Executing [s@sub-sugarcrm:6] UserEvent("SIP/trunk_ovh-0000000d", "dialplan2cti,UNIQUEID: 1392145499.13,CHANNEL: SIP/trunk_ovh-0000000d,VARIABLE: sugarcrm-firstname,VALUE: ") in new stack
    -------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


    La seul différence que je voit est sur "SUGARCRM-FIRSTNAME" ...

Les tags pour cette discussion

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •