Page 2 sur 3 PremièrePremière 123 DernièreDernière
Affichage des résultats 11 à 20 sur 21

Discussion: [RÉSOLU] Problème d'appel sortant mais pas entrant.

  1. #11
    Membre Junior
    Date d'inscription
    dcembre 2010
    Messages
    23
    Downloads
    0
    Uploads
    0
    J'ai essayer de changer la syntaxe et l'erreur est différente.

    Code:
        -- Executing [00158181010@users:1] Dial("SIP/13-00000002", "SIP/0158181010/ovh-out") in new stack
    [Mar 13 16:57:36] WARNING[19899][C-00000002]: chan_sip.c:6160 create_addr: Purely numeric hostname (0158181010), and not a peer--rejecting!
    [Mar 13 16:57:36] WARNING[19899][C-00000002]: app_dial.c:2437 dial_exec_full: Unable to create channel of type 'SIP' (cause 20 - Subscriber absent)
      == Everyone is busy/congested at this time (1:0/0/1)
        -- Auto fallthrough, channel 'SIP/13-00000002' status is 'CHANUNAVAIL'
    ipbx-v2*CLI> exit
    Asterisk cleanly ending (0).
    Executing last minute cleanups
    ipbx-v2:/etc/asterisk# nano extensions.conf
    ipbx-v2:/etc/asterisk# /etc/init.d/asterisk restart
    Stopping Asterisk PBX: asterisk.
    Starting Asterisk PBX: asterisk.
    ipbx-v2:/etc/asterisk# asterisk -rvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvv
    Privilege escalation protection disabled!
    See https://wiki.asterisk.org/wiki/x/1gKfAQ for more details.
    Asterisk 11.7.0~dfsg-1+b1, Copyright (C) 1999 - 2013 Digium, Inc. and others.
    Created by Mark Spencer <markster@digium.com>
    Asterisk comes with ABSOLUTELY NO WARRANTY; type 'core show warranty' for details.
    This is free software, with components licensed under the GNU General Public
    License version 2 and other licenses; you are welcome to redistribute it under
    certain conditions. Type 'core show license' for details.
    =========================================================================
    Connected to Asterisk 11.7.0~dfsg-1+b1 currently running on ipbx-v2 (pid = 19920)
      == Using SIP RTP CoS mark 5
        -- Executing [00603357850@users:1] Dial("SIP/34-00000000", "SIP/0603357850/ovh-out,,r") in new stack
    [Mar 13 16:58:00] WARNING[19967][C-00000000]: chan_sip.c:6160 create_addr: Purely numeric hostname (0603357850), and not a peer--rejecting!
    [Mar 13 16:58:00] WARNING[19967][C-00000000]: app_dial.c:2437 dial_exec_full: Unable to create channel of type 'SIP' (cause 20 - Subscriber absent)
      == Everyone is busy/congested at this time (1:0/0/1)
        -- Auto fallthrough, channel 'SIP/34-00000000' status is 'CHANUNAVAIL'
           > Saved useragent "C610 IP/42.075.00.000.000" for peer 33

  2. #12
    Membre Junior
    Date d'inscription
    dcembre 2010
    Messages
    23
    Downloads
    0
    Uploads
    0
    Ah j'avais rechargé la page ... et ton message n'était pas là pendant les tests.

    Je retente avec : exten => _0.,1,Dial(SIP/ovh-out/${EXTEN:1},,r)

  3. #13
    Membre Junior
    Date d'inscription
    dcembre 2010
    Messages
    23
    Downloads
    0
    Uploads
    0
    Je retombe sur l'erreur que j'avais au début donc mon soucis doit être purement réseau ...

    Quand je regarde les appels reçu on voit qu'ils passent une "probation" mais pas les appels sortant.

    Code:
    Connected to Asterisk 11.7.0~dfsg-1+b1 currently running on ipbx-v2 (pid = 19988)
      == Using SIP RTP CoS mark 5
        -- Executing [00603357850@users:1] Dial("SIP/34-00000000", "SIP/ovh-out/0603357850,,r") in new stack
      == Using SIP RTP CoS mark 5
        -- Called SIP/ovh-out/0603357850
           > Saved useragent "C610 IP/42.075.00.000.000" for peer 31
    [Mar 13 17:01:23] WARNING[20021]: chan_sip.c:4175 retrans_pkt: Retransmission timeout reached on transmission 04e06f5c382749ed035a740c48cfaacf@80.12.90.15:5060 for seqno 102 (Critical Request) -- See https://wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions
    Packet timed out after 6400ms with no response
    [Mar 13 17:01:23] WARNING[20021]: chan_sip.c:4204 retrans_pkt: Hanging up call 04e06f5c382749ed035a740c48cfaacf@80.12.90.15:5060 - no reply to our critical packet (see https://wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions).
      == Everyone is busy/congested at this time (1:0/0/1)

  4. #14
    Membre Association Avatar de quintana
    Date d'inscription
    aot 2010
    Localisation
    Québec
    Messages
    1 084
    Downloads
    0
    Uploads
    0
    Mouais spécial par exemple ... En tout cas avec ce qu'on voit oui, maintenant pourquoi il fait cela c'est autre chose. Vraiment faut que tu lances du tcpdump pour voir ce qu'il se passe, mais j'ai l'impression que tu n'as pas la maîtrise de cela vu ce que tu as écrit auparavant. En tout cas pour moi c'est pas un souci Asterisk en tant que tel, tu as un autre truc qui c'est passé. Un firewall sur le serveur ?

    iptables -L -n ?
    Découvrez Wazo sous licence GPLv3 et accessible pour tous : http://www.wazo.community
    Blog Wazo : http://blog.wazo.community
    Wazo est un fork de XiVO.
    Suivez moi sur Twitter !

  5. #15
    Membre Senior
    Date d'inscription
    septembre 2010
    Localisation
    Where the sun shines
    Messages
    1 418
    Downloads
    0
    Uploads
    0
    comme le dit le message:

    no reply to our critical packet (see https://wiki.asterisk.org/wiki/displ...etransmissions)

    le doc indiqué est pas mal à lire.... c'est un problème typique de réseau - un paquet n'est pas acquitté correctement, et bye-bye... pourquoi, ca c'est compliqué... pbm de firewall ? je doute que tu n'en aies pas, ou alors donne moi vite ton ip que je te pirate avant les quelqu'un d'autre.... quoique, en cherchant dans les messages, j'ai trouvé ton ip et tes trois caméras - cuisine, openspace, entree....

  6. #16
    Membre Association Avatar de quintana
    Date d'inscription
    aot 2010
    Localisation
    Québec
    Messages
    1 084
    Downloads
    0
    Uploads
    0
    Ces messages sont juste des warning, mais c'est clairement un souci réseau quelques parts.
    Découvrez Wazo sous licence GPLv3 et accessible pour tous : http://www.wazo.community
    Blog Wazo : http://blog.wazo.community
    Wazo est un fork de XiVO.
    Suivez moi sur Twitter !

  7. #17
    Membre Junior
    Date d'inscription
    dcembre 2010
    Messages
    23
    Downloads
    0
    Uploads
    0
    Citation Envoyé par jean Voir le message
    comme le dit le message:

    no reply to our critical packet (see https://wiki.asterisk.org/wiki/displ...etransmissions)

    le doc indiqué est pas mal à lire.... c'est un problème typique de réseau - un paquet n'est pas acquitté correctement, et bye-bye... pourquoi, ca c'est compliqué... pbm de firewall ? je doute que tu n'en aies pas, ou alors donne moi vite ton ip que je te pirate avant les quelqu'un d'autre.... quoique, en cherchant dans les messages, ...
    Merci mais déjà lu cette doc à l'époque ou le problème était qu'il fallait préciser le réseau externe et interne d'asterisk. Quant à citer les caméra c'est pas obligé de mettre en public. Ce serait bien sympa de modifier ton message. Merci.

  8. #18
    Membre Junior
    Date d'inscription
    dcembre 2010
    Messages
    23
    Downloads
    0
    Uploads
    0
    Citation Envoyé par quintana Voir le message
    Ces messages sont juste des warning, mais c'est clairement un souci réseau quelques parts.
    Oui pareil je ne vois plus que ça comme à l'époque ou j'ai eu ce message et la solution était de rajouter justement l'ip externe et le network interne pour qu'Asterisk ne se prenne pas les pieds dans le tapis. Je pensais que ce serait pareil cette fois ci.

    Je vais voir avec la personne qui gère le réseau.

    Merci pour votre aide, je vous tiens au courant surtout si ca peut aider quelqu'un d'autre.

  9. #19
    Membre Junior
    Date d'inscription
    dcembre 2010
    Messages
    23
    Downloads
    0
    Uploads
    0

    Exclamation envoi trop rapide du post sans les remerciements de base de la politese !

    Bon il s'avère que le soucis venait du codec g729 chez OVH et en le désactivant ca a permis de ne rester qu'en ulaw et le téléphone refonctionne à nouveau !

    Voila le truc tout bête bien que j'ai encore un peu de mal à comprendre le pourquoi du comment encore.

    En tout cas merci pour l'aide apportée !

  10. #20
    Membre Association Avatar de quintana
    Date d'inscription
    aot 2010
    Localisation
    Québec
    Messages
    1 084
    Downloads
    0
    Uploads
    0
    La prochaine fois faut penser à faire un sip set debug on et de regarder les messages
    Normalement on le voit dans la cli plus facilement cette erreur de négociation, bizarre.
    Découvrez Wazo sous licence GPLv3 et accessible pour tous : http://www.wazo.community
    Blog Wazo : http://blog.wazo.community
    Wazo est un fork de XiVO.
    Suivez moi sur Twitter !

Les tags pour cette discussion

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •