Affichage des résultats 1 à 4 sur 4

Discussion: [RESOLU] Asterisk 14 et ligne OVH : pas de son depuis PC en appel sortant

  1. #1
    Membre Junior
    Date d'inscription
    mai 2017
    Messages
    3
    Merci
    0
    Remercié 0 Fois en 0 Posts

    Downloads
    0
    Uploads
    0

    Question [RESOLU] Asterisk 14 et ligne OVH : pas de son depuis PC en appel sortant

    Hello,

    J'ai un petit soucis avec Asterisk 14 et OVH... J'ai beau retourner le problème dans tous les sens, faire des recherches Google RIEN-NE-MARCHE :(

    Je m'explique : J'ai donc la ligne qui est configurée, elle tourne nickel en appel entrant. Mais en appel sortant, impossible d'entendre celui que j'appelle alors que lui m'entend bien.

    Voici mes fichiers sip.conf et extensions.conf (je ne reprend que les parties les plus intéressantes)

    Code:
    sip.conf
    =====
    
    [general]
    directmedia=no
    externip=79.137.38.233
    register => 003210XXXXXX:motdepasse@sip3.ovh.be
    context=ovh-sip
    
    [ovh-sip]
    type=peer 
    host=sip3.ovh.be 
    context=ovh 
    language=fr 
    insecure=port,invite
    username=003210XXXXXX
    secret=motdepasse
    nat=yes 
    canreinvite=no 
    dtmfmode=auto 
    video=no 
    restrictcid=no 
    amaflags=default
    Code:
    extensions.conf
    ==========
    [general]
    static=yes
    writeprotect=no
    clearglobalvars=no
    insecure=port,invite
    
    [globals]
    CONSOLE=Console/dsp
    IAXINFO=guest
    TRUNK=Zap/g2
    TRUNKMSD=1
    
    [public]
    exten => sip,1,Dial(SIP/secretaire)
    
    [ovh]
    exten => s,1,Dial(SIP/secretaire)
    
    [work]
    exten => _04XXXXXXXX,1,Dial(SIP/${EXTEN}@ovh-sip)
    Si quelqu'un trouve la solution, je le vénérerai jusque la fin de mes jours car ça fait 3 jours que je cherche

    Merci à tous!
    Dernière modification par izanagi1995 ; 21/05/2017 à 23h55. Motif: Résolu

  2. #2
    Membre Senior
    Date d'inscription
    septembre 2010
    Localisation
    Where the sun shines
    Messages
    1 350
    Merci
    6
    Remercié 45 Fois en 45 Posts

    Downloads
    0
    Uploads
    0
    - je tenterai de virer le nat=yes, les deux machines sont sur des ip publiques
    - il faut aussi que ce soit bien ton ip publique, externip=79.137.38.233, mais en toute logique, il faut aussi un localnet=
    - fais un rtp set debug on avnt un appel, et regarde les @ ou sont envoyés/reçus les paquets

  3. #3
    Membre Junior
    Date d'inscription
    mai 2017
    Messages
    3
    Merci
    0
    Remercié 0 Fois en 0 Posts

    Downloads
    0
    Uploads
    0
    Salut jean,

    Merci de ta réponse.

    J'ai viré le nat, sans succès... Pour externip, c'est bien la bonne. localnet, comme c'est un serveur dédié externe, j'en ai pas besoin, si?

    Avec rtp set debug on, les ips sont les bonnes...

    Got RTP packet from MONIP:4004 (type 00, seq 022259, ts 000160, len 000160)
    Sent RTP packet to OVH:31022 (type 08, seq 028594, ts 000160, len 000160)
    Got RTP packet from MONIP:4004 (type 00, seq 022260, ts 000320, len 000160)
    Sent RTP packet to OVH:31022 (type 08, seq 028595, ts 000320, len 000160)
    Got RTP packet from OVH:31022 (type 08, seq 004947, ts 29841485, len 000160)
    Sent RTP packet to MONIP:4004 (type 00, seq 008782, ts 29841480, len 000160)
    Got RTP packet from OVH:31022 (type 08, seq 004948, ts 29841645, len 000160)

  4. #4
    Membre Junior
    Date d'inscription
    mai 2017
    Messages
    3
    Merci
    0
    Remercié 0 Fois en 0 Posts

    Downloads
    0
    Uploads
    0
    Mystérieusement, en ajoutant ceci à [general] dans sip.conf, ça a marché

    directmedia=yes ; J'ai changé de no à yes
    language=fr
    canreinvite=no
    defaultexpiry=3600
    disallow=all
    allow=ulaw

    Explications?

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •