Affichage des résultats 1 à 8 sur 8

Discussion: Asterisk-15.x.x

  1. #1
    Membre Junior
    Date d'inscription
    dcembre 2017
    Messages
    5
    Downloads
    0
    Uploads
    0

    Angry Asterisk-15.x.x

    Salut à tous!
    Moi c'est Ario et je viens de découvrir ce forum.

    Sinon voilà ça fait plus de 48H que j'essaye d'installer asterisk-15.x.x ( les version 15 ) sur une machine Debian 9 mais j'y arrive pas car j'ai ce message d'erreur (voir fichier joint) alors qu'avec ubuntu 17.10 ça marche implacablement.


    Alors si possible, j'aimerais que vous me guidez car ça me ronge de ne pas y arriver.

    Cordialement.
    Fichiers attachés Fichiers attachés

  2. #2
    Asterisk Fan Avatar de fastm3
    Date d'inscription
    aot 2010
    Localisation
    Corbeil Essonnes (91)
    Messages
    1 302
    Downloads
    1
    Uploads
    1
    Pas encore regardé mais que donne deja un wget https://raw.githubusercontent.com/as...-2.7.1.tar.bz2 ?
    Tu as bien verifié connectivité internet , place disque sur /tmp, droits sur /tmp ? ca doit etre un truc comme cela...
    ( pas de probleme jusque la pour moi sur une debian 9 avec asterisk-15.2.0-rc1 ) . Cette debian 9 n'a pas toutes les dependances donc le configure echoue pour moi aussi mais bien apres et ca serait resolu en installant quelques paquets.
    Francois.
    Dernière modification par fastm3 ; 29/12/2017 à 00h58.

  3. #3
    Membre Junior
    Date d'inscription
    dcembre 2017
    Messages
    5
    Downloads
    0
    Uploads
    0
    Citation Envoyé par fastm3 Voir le message
    Pas encore regardé mais que donne deja un wget https://raw.githubusercontent.com/as...-2.7.1.tar.bz2 ?
    Tu as bien verifié connectivité internet , place disque sur /tmp, droits sur /tmp ? ca doit etre un truc comme cela...
    ( pas de probleme jusque la pour moi sur une debian 9 avec asterisk-15.2.0-rc1 ) . Cette debian 9 n'a pas toutes les dependances donc le configure echoue pour moi aussi mais bien apres et ca serait resolu en installant quelques paquets.
    Francois.


    J'ai fait la procédure et voilà ce que ça me donne;


    ario@debian:/tmp/downloads$ wget https://raw.githubusercontent.com/as...-2.7.1.tar.bz2
    --2017-12-29 02:52:31-- https://raw.githubusercontent.com/as...-2.7.1.tar.bz2
    Résolution de raw.githubusercontent.com (raw.githubusercontent.com)… 151.101.60.133
    Connexion à raw.githubusercontent.com (raw.githubusercontent.com)|151.101.60.133|:443… connecté.
    requête HTTP transmise, en attente de la réponse… 200 OK
    Taille*: 4880007 (4,7M) [application/octet-stream]
    Sauvegarde en*: «*pjproject-2.7.1.tar.bz2*»

    pjproject-2.7.1.tar 100%[===================>] 4,65M 64,1KB/s in 79s

    2017-12-29 02:53:56 (60,4 KB/s) — «*pjproject-2.7.1.tar.bz2*» sauvegardé [4880007/4880007]
    ario@debian:/tmp/downloads$ wget https://raw.githubusercontent.com/as...7.1/MD5SUM.TXT
    --2017-12-29 02:54:32-- https://raw.githubusercontent.com/as...7.1/MD5SUM.TXT
    Résolution de raw.githubusercontent.com (raw.githubusercontent.com)… 151.101.60.133
    Connexion à raw.githubusercontent.com (raw.githubusercontent.com)|151.101.60.133|:443… connecté.
    requête HTTP transmise, en attente de la réponse… 404 Not Found
    2017-12-29 02:54:38 erreur*404*: Not Found.

  4. #4
    Asterisk Fan Avatar de fastm3
    Date d'inscription
    aot 2010
    Localisation
    Corbeil Essonnes (91)
    Messages
    1 302
    Downloads
    1
    Uploads
    1
    tu as bien lancé
    Code:
    ./contrib/scripts/install_prereq install
    ?
    sinon et si tu n'as pas besoin de pjsip , tu peux toujours faire un
    Code:
     ./configure --without-pjproject-bundled
    pour voir si c'est ton seul probleme.
    Francois.

  5. #5
    Membre Junior
    Date d'inscription
    dcembre 2017
    Messages
    5
    Downloads
    0
    Uploads
    0
    Citation Envoyé par fastm3 Voir le message
    tu as bien lancé
    Code:
    ./contrib/scripts/install_prereq install
    ?
    sinon et si tu n'as pas besoin de pjsip , tu peux toujours faire un
    Code:
     ./configure --without-pjproject-bundled
    pour voir si c'est ton seul probleme.
    Francois.
    pjsip sert à quoi au juste? Je peux m'en passer?

  6. #6
    Asterisk Fan Avatar de fastm3
    Date d'inscription
    aot 2010
    Localisation
    Corbeil Essonnes (91)
    Messages
    1 302
    Downloads
    1
    Uploads
    1
    Si tu poses la question, c'est que oui , tu peux t'en passer. Tu utiliseras seulement le bon vieux chan_sip qui perso, me convient tres bien encore. Pjsip remplacera probablement a terme chan_sip mais pour l'instant , je prefere toujours chan_sip en prod. Si tu poses la question et si tu bloques sur des problèmes de compils sans pouvoir debugguer , tu peux aussi jeter un coup d'oeuil aux distribs type wazo , freepbx...
    Cheers !
    Francois.

  7. #7
    Membre Association Avatar de quintana
    Date d'inscription
    aot 2010
    Localisation
    Québec
    Messages
    1 084
    Downloads
    0
    Uploads
    0
    Est-ce que le wget fonctionne ? Parce que ça ressemble à un souci que j'ai déjà vu de certificat SSL. Mais pjsip n'est pas obligatoire en effet, par contre si tu ne l'installes pas, tu n'auras pas certaines fonctionnalité dans Asterisk comme le chan_pjsip. Il me semble que sur l'aspect webrtc aussi c'est nécessaire, même dans chan_sip.
    Découvrez Wazo sous licence GPLv3 et accessible pour tous : http://www.wazo.community
    Blog Wazo : http://blog.wazo.community
    Wazo est un fork de XiVO.
    Suivez moi sur Twitter !

  8. #8
    Membre Junior
    Date d'inscription
    dcembre 2017
    Messages
    5
    Downloads
    0
    Uploads
    0
    Merci beaucoup pour vos réponse

    J'utilise maintenant asterisknow, c'est beaucoup plus simple^^

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •