Affichage des résultats 1 à 3 sur 3

Discussion: Asterisk, OVH et l'ouverture de port

  1. #1
    Membre Junior
    Date d'inscription
    avril 2018
    Messages
    9
    Merci
    0
    Remercié 0 Fois en 0 Posts

    Downloads
    0
    Uploads
    0

    Asterisk, OVH et l'ouverture de port

    Bonjour à tous,

    Je débute dans l'utilisation d'Asterisk et plus généralement de la téléphonie.

    J'ai un compte OVH SIP (pas un trunk), un serveur avec Asterisk installé dessus et deux téléphones derrière.
    Le tout derrière une box (je suis de Belgique, chez le provideur Voo et c'est une Technicolor, TC7210 je pense).

    Le paramétrage d'Asterisk est extrêmement simple (je l'ai dit je débute).

    Tout fonctionne comme je le veux sauf qu'après une ou deux minutes, plus moyen de passer des communications.

    Le log d'asterisk me dit:

    Code:
    [Apr 14 13:01:21] WARNING[595][C-00000024] chan_sip.c: Received response: "Forbidden" from '"x" <sip:0032xxxxx@sip3.ovh.be>;tag=as28fk716b'
    Tandis que du côte de OVH, j'ai ce message:

    Code:
    Different register invite port (14/04/2018 13:39) :
    Register port is : '61189' but invite port is '5060' :
    The invite request does not use the same port as the register. 403 expected
    Après des recherches, il s'avère que c'est un problème de NAT.
    J'ai dû créer trois règles NAT qui permette au serveur OVH sip3.ovh.be d'accéder aux ports 5060, 5962 et le range 35000-40000 en UDP du serveur Asterisk.

    Effectivement après avoir fait ça, ca fait maintenant quelques jours que ca tient.

    Par contre, je ne comprends pas du tout pq il faut faire cela ou même si c'est une solution viable.
    Pourquoi est-ce que le serveur Asterisk qui, pour moi, est un client du serveur SIP OVH doit jouer le rôle de serveur sur les ports UDP mentionnés.

    Je ne suis pas vraiment expert en réseau, et encore moins dans le protocole SIP mais est-ce que quelqu'un a une explication et/ou une solution plus "robuste" que d'ouvrir des ports même s'ils sont limités uniquement au serveur OVH ?

    Merci!

    lamazzi

  2. #2
    Membre Senior
    Date d'inscription
    septembre 2010
    Localisation
    Where the sun shines
    Messages
    1 402
    Merci
    7
    Remercié 52 Fois en 52 Posts

    Downloads
    0
    Uploads
    0
    pour recevoir des appels, il faut s'enregistrer - un message part vers ovh. certains routeurs remappent systématiquement le port utilisé (port source) et après un certain délai, surtout en udp, oublient ce mapping. du coup, quand le paquet suivant part, il est vu comme venant d'un autre port, et cause une erreur.
    idéalement, pas de nat, ou un routeur qui ne pose pas ce problème. aussi, désactiver les options SIP ALG du routeur, ces options sont censées récrire le protocole en tenant compte du nat, mais ca marche rarement.
    sinon, voir à passer en tcp si ovh le supporte,

    J.

  3. #3
    Membre Junior
    Date d'inscription
    avril 2018
    Messages
    9
    Merci
    0
    Remercié 0 Fois en 0 Posts

    Downloads
    0
    Uploads
    0
    Merci Jean pour ta réaction.
    Malheureusement aucun des solutions que tu proposes n'est envisageable. Ou alors il faut que j'utilise le Technicolor en mode bridge et mettre un routeur digne de ce nom derrière.
    Ceci dit, comme la règle NAT qui autorise les ports en question n'est autorisée que pour l'IP de OVH + j'ai relativement bien sécurisé la box pour éviter le brutforce et autre, je me dit que ce n'est pas non plus comme si elle était en pleine nature à attendre d'être hackée.

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •